LocatorHub and ArcGIS Compatibility making use of TLS 1.two

Enhance your income with thin and zero clientele
March 4, 2019
Ransomware: Not dead, just getting a lot sneakier
March 6, 2019

From February 2019 ArcGIS Online is only going to help TLS 1.2 (specifics obtainable right here).

If you use any ArcGIS Online functionality with LocatorHub then you could be impacted. Possible touchpoints are:

  • ArcGIS Map Service Locators

  • ArcGIS Feature Service Locators

  • ArcGIS Locators

  • Coordinate Conversion via ArcGIS Online

  • Using LocatorHub Locators within ArcGIS On-line by way of the ArcGIS Compatible REST endpoint

Regardless of no matter whether you are making use of any of these touchpoints, it is good practice to ensure you are making use of or have the capability of employing TLS 1.2. Some clients or database servers may enforce TLS 1.two communication.

Ensuring TLS 1.2 compatibility

LocatorHub has supported TLS 1.2 from version five.4 Service Pack 2. If you are employing a version reduce than this you will need to upgrade.

For all LocatorHub versions it will be necessary to make the following adjust to the LocatorHub net.config files (depending on which endpoint(s) you use):

  • If using LocatorHub regular REST/SOAP Endpoint and ArcGIS Compatible REST Endpoint:

    • C:inetpubwwwrootLocatorHubweb.config

  • If employing LocatorHub SOAP Endpoint (deprecated)

    • C:inetpubwwwrootLHweb.config

  • If employing LocatorHub Editable SOAP Endpoint

    • C:inetpubwwwrootLHEDITweb.config

For the endpoint(s) in use, inside the configuration file(s), locate the following line:

Edit this line by changing four. to 4.six.two, and add an additional line as beneath:

Save the modify(s) and then restart IIS.

Read The Original Article

Leave a Reply